Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We're using OpsView/Nagios to monitor our servers. We've added the SNMP service to all our servers and deployed the configuration via GPO, but one win2k3 server seems to have a problem; it crashes pretty regularly. The event log carries messages like:

Event Type: Error
Event Source:   Service Control Manager
Event Category: None
Event ID:   7034
Date:   	6/11/2009
Time:   	7:11:49 PM
User:   	N/A
Computer:   HOSTNNAME
Description:
The SNMP Service service terminated unexpectedly.  It has done this 2 time(s).

and also

Event Type: Error
Event Source:   Application Error
Event Category: (100)
Event ID:   1000
Date:   	6/11/2009
Time:   	7:11:18 PM
User:   	N/A
Computer:   HOSTNAME
Description:
Faulting application snmp.exe, version 5.2.3790.3959, faulting module ntdll.dll, 
version 5.2.3790.3959, fault address 0x000417af.

Now, I could probably set it to simply restart on crash in perpetuity, but I think it's better to fix problems like this. Is this a known problem? If not, what should I do to diagnose it?

share|improve this question
    
Can't say it's a "known" problem, but it keeps happening to me too. –  David Mackintosh Jun 13 '09 at 0:22
    
Curious: Why use SNMP over NSClient++? –  MichaelGG Jun 13 '09 at 3:13
    
Let's say that the moment that it has been "decided" to use SNMP, for now. –  jldugger Jun 13 '09 at 6:23
add comment

3 Answers

I had this type of issue before. Check for snmp agent extension. Dell and others add extension to the snmp service, and may cause crash due to missing dll & co.

I blogged about it, that was Arcserve the guilty at this time

Compare this hive with others servers: HKLM\SYSTEM\CurrentControlSet\

Services\SNMP\Parameters\ExtensionAgents

You may also use Process explorer to track snmp service behavior

share|improve this answer
add comment

I also had a similar problem and Mathieu's solution helped me. In my case there was a registry with the following name .

"aussnmp"="SOFTWARE\\Adaptec\\RAIDController\\AAC\\CurrentVersion"

Deleting this solved the problem.

Btw, this is on Windows Server 2008 R2 enterprise on DELL hardware.

share|improve this answer
    
@user70410, I navigated to a similar registry value: "Pathname"="C:\\Program Files\\Adaptec\\Adaptec Storage Manager\\aus-snmp.dll" Deleting this solved my problem. Thanks! –  northben Apr 9 '12 at 22:11
    
HKEY_LOCAL_MACHINE\SOFTWARE\Adaptec\RAIDController\AAC\CurrentVersion\Pathname Deleting this key helped me –  user150791 Dec 24 '12 at 2:28
add comment

I've had some intermittent issues with this same thing on physical SuperMicro servers at SoftLayer. I found deleting both the following keys seems to fix the issue.

HKEY_LOCAL_MACHINE\SOFTWARE\Adaptec\RAIDController\AAC\CurrentVersion\aussnmp 
HKEY_LOCAL_MACHINE\SOFTWARE\Adaptec\RAIDController\AAC\CurrentVersion\Pathname
share|improve this answer
add comment

protected by HopelessN00b Genius of network Dec 24 '12 at 2:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.