Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

OK, I am a Linux/Eclipse developer with past experience as a MS VS developer. I am now trying to straighten out a Windows 7 Ultimate development machine where I am unable to get Apache running because I am sure something has ports 80, 8080 and 443. I ran netstat -ab |more and found that "proto" had grabbed 0.0.0.0:80 and is LISTENING and is active. See below:

Active Connections



  Proto  Local Address          Foreign Address        State

  TCP    0.0.0.0:80             sapinforma:0           LISTENING

 Can not obtain ownership information

  TCP    0.0.0.0:135            sapinforma:0           LISTENING

  RpcSs

 [svchost.exe]

  TCP    0.0.0.0:445            sapinforma:0           LISTENING

 Can not obtain ownership information

  TCP    0.0.0.0:554            sapinforma:0           LISTENING

 [wmpnetwk.exe]

  TCP    0.0.0.0:1433           sapinforma:0           LISTENING

 [sqlservr.exe]

  TCP    0.0.0.0:2383           sapinforma:0           LISTENING

 [msmdsrv.exe]

  TCP    0.0.0.0:2492           sapinforma:0           LISTENING

 [GROOVE.EXE]

  TCP    0.0.0.0:2869           sapinforma:0           LISTENING

 Can not obtain ownership information

  TCP    0.0.0.0:5357           sapinforma:0           LISTENING

 Can not obtain ownership information

  TCP    0.0.0.0:8019           sapinforma:0           LISTENING

What I want to know is what is proto and how to kill whatever is using 80, 8080 and 443. You can see in the pic that 443 is bound to wmpnetwk.exe.

Anybody, my accept rate on stackoverflow is around 100%

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

In Windows 7, the NT kernel by default uses port 80, through http.sys. You can verify this by checking the process ID of the process listening on that port, it should be something around 3 or 4. You can disable it by doing the following:

  1. Open HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
  2. Add a new DWORD (32-bit) value named NoRun with a value of 1
  3. Re-boot your computer

And from your post, wmpnetwk.exe is using port 1433, not 443.

share|improve this answer
    
Thanks, thats it.. So what did I actually disable by NoRun'g http.sys. Can you provide a bit of background on what http.sys is used for and why it has 80 of all ports..Is that part of MS's newer security features.. –  apesa Mar 23 '11 at 15:35
    
I believe it's a basic component of IIS. Why it's on by default on Win7, I have no idea. –  Hyppy Mar 23 '11 at 15:59
    
This whole windows 7 security permissions thing is horribly complex, I am glad I don't have to work fulltime on this. Thanks again –  apesa Mar 23 '11 at 16:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.