Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a user running xp sp2 that keeps getting "The Recycle Bin on C:\ Is Corrupt or Invalid." kb297760 says that this can be caused if the subst command is used to map a drive to an existing folder. Some software they use actually does do this (DocumentFX from CCH) and MS provides a hotfix, however this fix is for sp1... I have also tried logging in as admin and resetting NTFS rights on c:\RECYCLER to the defaults with no luck. I would like to avoid upgrading to sp3 if possible - not sure that will even fix the problem. Thanks.

share|improve this question
up vote 1 down vote accepted

You won't have the error from 297760 if you're running SP2. Could this Compaq knowledge base article help?

(It says to remove c:\recycled but it may actually mean c:\recycler).

share|improve this answer
yes, it is the recycler folder that is corrupt. – andymoe Jun 13 '09 at 2:24
I will try the KB from compaq and let you know. Thanks. – andymoe Jun 13 '09 at 2:35
In XP simply deleting c:\recycler via command line (rd /s c:\recycler) and rebooting fixed it. It will probably happen again unless I upgrade to SP3 but the PC is slated to be replaced next week... – andymoe Jun 18 '09 at 6:42

You can try using this reg file (there seems to be no way to attach a file so here's the entries):

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace{645FF040-5081-101B-9F08-00AA002F954E}] @="Recycle Bin"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID{645FF040-5081-101B-9F08-00AA002F954E}] @="Recycle Bin" "InfoTip"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,\ 6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,\ 00,53,00,48,00,45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,\ 2d,00,32,00,32,00,39,00,31,00,35,00,00,00 "SortOrderIndex"=dword:00000060 "IntroText"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,\ 6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,\ 00,53,00,48,00,45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,\ 2d,00,33,00,31,00,37,00,34,00,38,00,00,00 "LocalizedString"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,\ 6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,\ 00,5c,00,53,00,48,00,45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,\ 2c,00,2d,00,38,00,39,00,36,00,34,00,00,00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID{645FF040-5081-101B-9F08-00AA002F954E}\DefaultIcon] @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\ 00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,00,\ 65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,33,00,31,00,00,\ 00 "Empty"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,\ 00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,\ 68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,33,00,31,\ 00,00,00 "Full"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,\ 00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,\ 68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,33,00,32,\ 00,00,00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID{645FF040-5081-101B-9F08-00AA002F954E}\InProcServer32] @="shell32.dll" "ThreadingModel"="Apartment"






[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder] "Attributes"=hex:40,01,00,20 "CallForAttributes"=dword:00000040

share|improve this answer

Upgrade to SP3. Its been fixed. Its not feasible or reasonable to get every patch in any order you want them in.

share|improve this answer
The program is documentfx by CCH. Uses the subst command to map to a deeply nested folder. MS says that subst can cause this reycle bin corruption as stated in kb297760 – andymoe Jun 13 '09 at 2:28

I've seen this on a Win2008 terminal server and it was due to a corrupted profile. Deleting the profile and getting the user to log back in fixed it.

Back up the users Desktop, Favorites and My Documents first, or you won't be popular. I speak from experience :-)


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.