Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting this error when complinng Apache with mod-mime-magic:

--enable-mime-magic ../build_apache.sh: line 22:

--enable-mime-magic: command not found

When I look at the output on screen, I see the following:

checking whether to enable mod_mime_magic... no

despite the fact that --enable-mime-magic is passed in the build script. Also, a little later, I see this:

checking whether to enable mod_mime... yes (default)

I googled this error, but not much comes up. Any ideas on what might be causing this?

Here is the build script:

PATH=/usr/bin:/bin:/lib

export PATH

set -e
set -x

make distclean || true

./configure --prefix=/app/apache \
        --enable-so \
        --enable-cgi \
        --enable-info \
        --enable-rewrite \
        --enable-speling \
        --enable-usertrack \
        --enable-deflate \
#       --enable-ssl \
#       --with-ssl=/usr/bin \
        --enable-mime-magic
#make
#make install
#/app/apache/bin/apachectl restart

This is on Apache 2.2.17 and Redhat (RHEL) 5.5.

Thanks!

KM

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Remove the commented lines from your ./configure list. They are causing --enable-mime-magic to be processed as a separate command.

share|improve this answer
    
DOUH! Thanks @slillibri! –  KM. Mar 23 '11 at 23:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.