Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm a Fedora (well linux actually!) novice and I am trying to install some software but am having problems.

It is a .tar.gz file and I've extracted it using tar -zxvf, and that has given me a .bin file. This is where i am stuck, as I can't find anywhere that says how to install a .bin file on Fedora. It's in a directory that I've given full permissions to my user to exectue files from.

Does anyone know if it is possible to install a .bin file, or has ever done it and could give me some pointers?

share|improve this question

1 Answer 1

A file extension alone tells nothing in the Linux world. But I would guess it's some kind of an executable file. Have you tried running it by first giving it execute permissions with chmod +x file.bin, and then doing ./file.bin on the directory the file resides?

You should see if the package can be found from the system's own software repositories first, though. It'll help you manage what all you have installed, and provides version updates in a centralized way.

share|improve this answer
1  
Thanks for your reply jho. I htink that permissions may be something to do with this, but I can't seem to change the permissions for the .bin file. I changed them for the .tar.gz earlier to execute and that worked but when I try to change it for this file so I can run it it says: "chmod: changing permissions of 'file.bin': read-only file system –  5lovak Mar 24 '11 at 14:14
    
@5lovak: Woah, is the .bin in the same directory you successfully changed permissions in for the .tar.gz? It's definitely not a good sign if a file system suddely goes into read-only mode, that can indicate severe problems with your hard drive or file system, not the file alone. What's the output of mount, and where is the .bin file located? Also if everything else is working fine, you should try moving the .bin elsewhere, like your home directory or /tmp and see if you can change its permissions there. –  jho Mar 24 '11 at 18:23
    
I think that the VM might be screwed. I have tried some more but had to leave this for the time being until I get a chance to re-install. Thanks very much for your advice though jho. –  5lovak Apr 15 '11 at 15:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.