Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I just purchased a VPS system to host my blog network, and while everything's working, I'm still having a few lingering issues.

My domains are all hosted through another provider and point to the IP address of my VPS. My Network is configured to use subdomains: *.eamann.com. All of the subdomains work, and I'm very happy with the network.

Next comes domain mapping. I installed the latest version of the WordPress MU Domain Mapping plug-in and configured it the same was as I did on my previous shared hosting. Once I had things set up, the regular .com domains were displaying the correct content. I'd use the regular .com domain to log in (site.com/wp-admin) and I was redirected to the right subdomain and logged in to the system.

But this is where the weirdness started. When I went back to the front page of the site (the regular .com address), I was no longer logged in.

It's a confusing problem indeed, and I'm at my wit's end trying to figure it out. If you want to take a crack and try to help, here are the details.

  • I'm running 9 sites in a Multisite network configured for subdomains.
  • I'm using version 0.5.4 of WordPress MU Domain Mapping
  • My VPS is running CentOS 5.5 with Apache 2.2.3, MySQL 5.0.77, and PHP 5.1.6

Below is the Virtual Host configuration I'm using in Apache to point everything at the right place. The domain I'm specifically having issues with is prosepainting.com. It's supposedly the mapped domain for prose.eamann.com. Both domains are hosted with 1and1 Internet and pointed to my VPS using an A Record (pointing to IP

<VirtualHost *:80>
    ServerName prosepainting.com
    ServerAlias http://www.prosepainting.com *.prosepainting.com
    DocumentRoot /var/www/html/eamann
<VirtualHost *:80>
    ServerName prose.eamann.com
    DocumentRoot /var/www/html/eamann
<VirtualHost *:80>
    ServerName business.eamann.com
    DocumentRoot /var/www/html/eamann
<VirtualHost *:80>
    ServerName eamann.com
    ServerAlias http://www.eamann.com *.eamann.com
    DocumentRoot /var/www/html/eamann

I'm pretty sure this is a configuration issue on my end, but I'm not sure where. Any idea where I should look or what I can do to diagnose?

And before you suggest I ask this on the WordPress Stack Exchange, I'm asking here because I think it's a server issue, not a WordPress issue ...

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Figured it out. Nothing was configured incorrectly on the server, just on my own machine.

While I'd directed all of the .eamann.com subdomains and the mapped domain (prosepainting.com) at the correct IP address, I still hadn't directed the central domain (eamann.com) at the new server since it's hosting a live site. When WordPress tried to log me in across the sites in the network, it tried to talk to eamann.com and choked because it was talking to a different server.

Setting my Windows hosts file to direct eamann.com to the appropriate server corrected the issue ... at least for this machine. Once the migration is complete, everything should be just fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.