Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Uploading files in our app works fine until we hit one that's > 2GB.

error_log shows:

Invalid Content-Length
(-3)Unknown error: Error reading request entity data

I've rebuilt the latest apache 64bit with large file support and I still get this error. Any ideas?

share|improve this question
I'm having this problem too, and I'm using the latest Apache/PHP and CentOS 5.7 64-bit. PHP limits are set to above 4GB, but still cannot upload anything over 2GB?! – Reado Jan 12 '12 at 17:15
How about disk space? You have enough? Post output from df -kh assuming you're on a linux/unix box. – KM. Jun 30 '12 at 2:07

The problem could also be on the client side. Some Webbrowsers do funny things with files bigger than 2GB. A good summary can be found here. Basically try first with a WebKit browser like Chrome or Safari. (These for sure are capable to send files bigger than 2GB correctly.)

share|improve this answer
Neither Chrome nor Safari use Gecko. – mgorven Jun 29 '12 at 23:51
Sure, I meant WebKit and did correct the answer... Sorry for the confusion. – loomi Jul 3 '12 at 8:27

Try checking your .htaccess file. You can modify that to allow larger uploads.

The .htaccess file should look something like this :

php_value upload_max_filesize 20M
php_value post_max_size 20M
php_value max_execution_time 200
php_value max_input_time 200

Or you can also change this setting in your php.ini.

share|improve this answer
…assuming of course that the original poster is running PHP. Hey, @raoul, what are you running? – MikeyB Mar 24 '11 at 17:22
ya. He said apache so I figured it would be PHP. – Physikal Mar 24 '11 at 17:31
We don't use PHP, this is a Perl application. – raoul Mar 25 '11 at 11:52
Anybody think of anything else? – raoul Mar 30 '11 at 14:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.