Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm aware that his question should maybe be posted on SuperUser. But as it probably has something to do with the Samba server, i'm posting it here.

I'm trying to mount one of my Samba shares in Mac OS X, but haven't had any luck yet. I'm able to mount the same share as a networkdrive in Windows XP.

I have tried to mount it in various ways, CMD+K in finder and the following command in terminal mount_smbfs ⁄⁄dev_domain_tld@ /Users/philip/share

The output of that command is just the help thingy, i have tried many possible combinations

usage: mount_smbfs [-Nh] [-d mode] [-f mode]
               //[domain;][user[:password]@]server[/share] path

Samba config on FreeBSD:

workgroup = domi
hosts allow =
server string = Webserver
security = share
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
remote announce =
local master = no
wins server =
dns proxy = no
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
template shell = /bin/nologin
winbind use default domain = no

comment = Home Directories
valid users = %S
writable = yes
browsable = yes

path = /home/web
read only = no
writeable = yes
browsable = no
valid users = myadminusername
share|improve this question

Maybe try to add a line netbios name = webserver to the [global] section and try your commands again with webserver instead of the IP address for the server name.

What string did you use in your attempt to connect via finder? What should work is smb://philip@ or whatever your username on FreeBSD is instead of philip. What error message did you get there?

Also, you can configure your WINS server in the Advanced tab of the network preferences. This could help as well.

share|improve this answer
Added the netbios name and tried to connect via finder using this smb://dev_domain_tld@webserver/homes = invalid username/password. I also made sure that the WINS server is in Advanced tab – Phliplip Mar 25 '11 at 9:03
And you can log into Samba with the credentials for the user dev_domain_tld from Windows? – Sven Mar 25 '11 at 9:06
Yes, i have just disconnected and remounted it again in windows, using same credentials. Mapped '//webserver/dev_domain_tld', Clicked on 'Other user' typed in the credentials. And yes i'm aware that my previous comment was '..@webserver/homes' - just tried '..@webserver/dev_domain_tld' still saying wrong user/pass. – Phliplip Mar 25 '11 at 9:18
Could it be a difference in the authentification method in Win vs. Mac ? Accoring to this thread OP has had the opposite problem… – Phliplip Mar 25 '11 at 9:20
You don't need WINS server to mount a share – BobC Mar 26 '11 at 8:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.