Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My Ubuntu server is EST, but all times in Jira are UTC.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You need to add a JVM parameter:

-Duser.timezone=EST

Add this to the JAVA_OPTS variable in setenv.sh (or setenv.bat if you're on Windows) in the bin subdirectory of your installation and restart JIRA.

share|improve this answer
    
Fabulous, thanks. I played with the setting further and used -Duser.timezone=America/New_York to get Jira to pick up EDT properly. –  ed209 Mar 27 '11 at 23:14
1  
To elaborate on setting JVM parameters on startup: confluence.atlassian.com/display/JIRA/… –  Jess Telford Jun 21 '11 at 7:01

It's a good practice too keep all the systems on UTC, database and servers.

The only place where people should use the local timezone is the last step, the client.

Otherwise sooner or later you will reach the point where you get the datatime altered, especially when migrating data.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.