Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to build up my new NAS with CentOS 6 or Scientific Linux 6, but I am not able to build the RAID5. I created a new RAID-device using mdadm, but after some hours of work, mdadm marked one or two hard disks as failing and degraded the array. Each time it marked different hard disks as failing. I tried it on Fedora 13, CentOS 5.5 and Scientific Linux 6.0.
All components are new, and the S.M.A.R.T. values show no errors.

... after many errors ...
ata6.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata6.00: failed command: READ DMA EXT
ata6.00: cmd 25/00:00:ff:2d:5c/00:01:90:00:00/e0 tag 0 dma 131072 in
        res 40/00:14:e7:45:46/00:00:90:00:00/40 Emask 0x4 (timeout)
ata6.00: status: { DRDY }
ata6: hard resetting link
ata6: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
ata6.00: configured for UDMA/133
sd 6:0:0:0: [sdd] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
sd 6:0:0:0: [sdd] Sense Key : Aborted Command [current] [descriptor]
Descriptor sense data with sense descriptors (in hex):
       72 0b 00 00 00 00 00 0c 00 0a 80 00 00 00 00 00 
       00 00 00 e6 
sd 6:0:0:0: [sdd] Add. Sense: No additional sense information
sd 6:0:0:0: [sdd] CDB: Read(10): 28 00 90 5c 2d ff 00 01 00 00
end_request: I/O error, dev sdd, sector 2421960191
raid5:md0: read error not correctable (sector 2421960128 on sdd1).
raid5: Disk failure on sdd1, disabling device.
raid5: Operation continuing on 4 devices.
raid5:md0: read error not correctable (sector 2421960136 on sdd1).
...

What could cause these problems?


My system:
Mainboard: Intel DH57JG
CPU: Intel Core i3-540
RAM: Corsair XMS3 2GB DDR3
PSU: Seasonic S12II-330Bronze
SATA-Controllers: 4x on board, 2x PCIe-Controller with JMB363-Chipset
HDDs: 6x Western Digital WD20EARS

The log of the last try:
shortened log, full log

share|improve this question

2 Answers 2

The WD20EARS are the Caviar Green models, right?

I wonder if they're "being green" and spinning down after a period of inactivity, causing mdadm to think they've died. That would probably also account for different drives dropping out.

I know some WD hard disks have trouble in RAID arrays because the firmware does some error checking and doesn't respond quick enough, so the host considers it to be failed. I've only really heard about this in hardware RAID arrays, but it might well be applicable in this scenario too.

At the end of the day, consumer disks doing any kind of RAID is never going to be perfect and your mileage may vary.

share|improve this answer
    
As I understand it, the variable rotation speed / frequent spin-down of the "green" disks results in enough latency for some requests that the drive is detected as failed by the RAID functionality. This article from WD might be relevant: wdc.custhelp.com/app/answers/detail/a_id/1397/p/227%2C294/… –  Slartibartfast Mar 26 '11 at 3:57

(I'm the same Dani31 as above, but I lost my user [wrote the entry on a live-cd])

I read many things about the WD20EARS because of Ben Pilbrow's answer and changed some things:

  • I set the load-cycle-time to 300s with wdidle3
  • and formatted the disks correctly (with 4K sectors) using fdisk -c -u /dev/sdX

After these changes, the building process was twice as fast, but failed again. This time it was the same drive that caused the abort (I think it were different drive-names becuase i used different distributions).

I looked at the kernel-logs and saw many reading errors, so i started badblocks on this drive and the same errors appeared in the kernel-logs.

I downloaded the Data Lifeguard Diagnostics Tool from Western Digital and started the Extended Test on the drive. The result was "too many errors found - replace drive".

I think the problem will be solved after i got my new drive.
Thank you for your help!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.