Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

hi i have installed snort with ipv6 supprt Version 2.9.0.2 IPv6 (Build 92) in RHEL. can anyone tell me how to enable ipv6 support in linux i tried

sysctl -w net.ipv6.conf.all.forwarding=1

and

echo 1 > /proc/sys/net/ipv6/conf/all/forwarding

and did service network restart but still i get error

Bringing up interface eth0:  Global IPv6 forwarding is enabled in configuration
, but not currently enabled in kernel.

then i added net.ipv6.conf.all.forwarding=1 in .etc/sysctl.conf , then rebooted now i dont see bthe above error msg but i dont see ipv6 forwarding from

can anyone please help

share|improve this question
    
Is the ipv6 kernel module loaded? Have you tried modprobe ipv6? –  Steven Monday Mar 26 '11 at 1:43
    
Forwarding also requires writing firewall rulesets; have you written firewall rules to forward packets yet? –  sarnold Mar 26 '11 at 8:17
    
@sarnold thanks for reply yes i have configured ip6tables & the rule in /etc/sysconfig/ip6tables. i have tried two rules in ip6tables -for all incoming tcp on eth0 , the target is nfqueue 6 - for all incoing tcp on etho0 , the target is ACCEPT both does not work –  sam Mar 27 '11 at 1:43
add comment

migrated from stackoverflow.com Mar 26 '11 at 9:39

This question came from our site for professional and enthusiast programmers.

3 Answers

For people looking to enable IPv6 forwarding but getting the Global IPv6 forwarding is disabled in configuration, but not currently disabled in kernel

Try adding IPV6FORWARDING=yes to /etc/sysconfig/network

share|improve this answer
add comment

To enable IPv6, you must have IPv6 support enabled in your kernel. Enabling IPv6 forwarding (as you are doing above) is useless in achieving that.

The following command will load the ipv6 module:

# modprobe ipv6

After that, you should have IPv6 link-local addresses added to your interfaces. For example:

# ip -6 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qlen 1000
    inet6 fe80::200:11ff:fe72:1aeb/64 scope link 
       valid_lft forever preferred_lft forever

If the above does not work, IPv6 support is not built in to your kernel, and must be upgraded. Consider running a modern Linux distro that includes IPv6 support out-of-the-box.

share|improve this answer
    
my kernel has ipv6 support. i have verified using modprobe -c . and i have assigned ipv6 addr to both interfaces. –  sam Mar 27 '11 at 1:47
    
Please provide the complete output of "ip -6 addr" in your question, and I will see if I can get any further. –  Jeremy Visser Mar 28 '11 at 12:19
add comment

Wonderful tutorial on what your looking to do: Link to That Tutorial

share|improve this answer
    
Hi William and welcome to ServerFault! Answers on our site are supposed to contain the actual canonical answer to the issue, not just be a link to a tutorial. Please revise this answer with the procedure from the tutorial and be sure to link the tutorial as a reference source. Thanks! –  Peter Grace Feb 9 '13 at 19:27
    
Actually just noticed this being a really old answer... Low chance of this being improved but worth noting anyway! –  Peter Grace Feb 9 '13 at 19:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.