Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've got (what I believe to be) a fresh installation of Server 2003 R2 (SP1), and while I've got perfect LAN connectivity, I can't access the Internet. I've tried pinging websites through Command Prompt, and I still get nothing. I've never used Server 2003 before, so I've got no idea what to look for. This box is plugged into the same switch as the computer that I'm typing this up on, so I know it's not that.

I checked, and I don't think that this is a dupe of this question, as I am about 99% sure that someone installed Server 2003 on this box then never used it - I doubt that it ever had internet connectivity to begin with.

EDIT: Apparently, I've got basic network connectivity now... I can ping the router at 192.168.0.1, but I still can't connect to the internet.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You've got layer 2 and layer 3 connectivity on the local network, what you may not have is layer 3 connectivity beyond the local network or you may have a name resolution problem. Try to ping and tracert to 8.8.8.8. If that's successful then your problem is a name resolution (DNS) problem and you'll need to look at the DNS settings on the server. If you can't ping or tracert to 8.8.8.8 then you've got a problem at the router, which could be a NAT problem or a firewall rule problem..

share|improve this answer
    
Here - img508.imageshack.us/img508/772/pingtracert.jpg - is a screenshot of the output. I'll have a look at the DNS settings and see what I can come up with. –  kivetros Mar 26 '11 at 16:19
1  
OK, based on the screenshot your problem is related to DNS name resolution, not connectivity. Look at the DNS client settings on the server and make sure it has a valid DNS server or servers set in the properties of the NIC. –  joeqwerty Mar 26 '11 at 16:30
    
Thanks so much - I had to install the DNS service from the installation disk - now everything's working just great. Thanks a lot! –  kivetros Mar 26 '11 at 16:38
1  
Glad to help... –  joeqwerty Mar 26 '11 at 16:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.