Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a home Nexenta Store CE server and after shutting it down to move it it will not boot up anymore.

It turns on and detects all 7 drives ( 6 data drives plus 1 smaller OS drive) then it gives me the blue Nexenta boot loader, I hit enter and it starts to boot but then suddenly I get an error (that goes away VERY fast, I had to use a camera on burst mode to get it!)

SunOS release 5.11 Version NexentaOS_134f 64-bit Loading Kernel... NOTICE: Can not read the pool label from '/pci@0,0/pci1043,83d4@1d,7/storage@1/disk@0,0;a' NOTICE: spa_import_rootpool: Error 5 cannot mount root on /(same as above) panic[cpu0/thread=fffffffffbc2e860: vfs_mountroot: cannot mount root

then it reboots and starts over.

any ideas?

if it gets that far seems to me the boot drive is ok?

Thanks.

share|improve this question
    
I've seen this happening when I upgraded Opensolaris 2009.6 to b134 and also zpool upgrade it. When I tried to go back to 2009.6, it would not understand the ZFS pool version on the disk. Do you have RAID on top of the disks? Are the volumes OK? This could also indicate it cannot open the disk but it seems unlikely. Your disk could also be corrupted.. try to load from a previous Boot Environment in the GRUB menu. –  gtirloni Mar 27 '11 at 17:22

2 Answers 2

This is because of the bootstrapping architecture in use by Solaris for x86/x64. The OS pool has a different device in its metadata than is currently reported. This is annoying, but has a solution: 1. boot failsafe 2. zpool import syspool 3. reboot

Note: this affects all Solaris systems, however not all Solaris distributions have a failsafe boot environment in grub.

share|improve this answer
up vote 0 down vote accepted

I figured this out, when I moved the machine I did not plug my boot drive back into the same usb port.

Shame on me for using USB as the boot drive but all my sata ports are in use until I get a controller :)

I had no idea it had to be in the same usb port though!

Ah well, it works now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.