Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows 2008 R2 Virtual Server. I removed the "Default Web Site" using IIS Manager and now all my other sites now report an error saying they can't access the site (or something similar).

I thought I could just remove the role, re-install IIS again and start with a clean slate.

After I re-installed IIS it's now reporting the following error in the event log:

The World Wide Web Publishing Service (WWW service) failed to register the URL prefix of "http://www.mash-guild.com:80:192.168.245.132/" for the website of "4". The required network connectivity may already be used. The site has been disabled. The data field contains the error number.

This is the full version with the german error note (I'm from germany):

Der WWW-Publishingdienst (WWW-Dienst) konnte das URL-Präfix 
"http://www.mash-guild.com:80:192.168.245.132/" für die Website "4" nicht registrieren.
Die erforderliche Netzwerkverbindung wird möglicherweise bereits verwendet. 
Die Website wurde deaktiviert. Das Datenfeld enthält die Fehlernummer. Ereignis-XML:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> 
    <System>
          <Provider Name="Microsoft-Windows-IIS-W3SVC" Guid="{05448E22-93DE-4A7A-BBA5-92E27486A8BE}" EventSourceName="W3SVC" />
          <EventID Qualifiers="49152">1007</EventID>
          <Version>0</Version>
          <Level>2</Level>
          <Task>0</Task>
          <Opcode>0</Opcode>
          <Keywords>0x80000000000000</Keywords>
          <TimeCreated SystemTime="2011-03-26T16:14:56.000000000Z" />
          <EventRecordID>1435</EventRecordID>
          <Correlation />
          <Execution ProcessID="0" ThreadID="0" />
          <Channel>System</Channel>
          <Computer>WIN-DCJ8SN0QI5J</Computer>
          <Security />
    </System>   
    <EventData>
        <Data Name="UrlPrefix">http://www.mash-guild.com:80:192.168.245.132/</Data>
        <Data Name="SiteID">4</Data>
        <Binary>B7000780</Binary>   
    </EventData> 
</Event>

I would like to know if there is a way to fix this or just get back to the IIS + Server settings I had just after I installed windows 2008 ?

share|improve this question
add comment

2 Answers

Few things --

  1. It looks like your other websites are erroring out because something or the other that they are using may be installed into the Default Web Site that you deleted. It is possible these components were being used as subdirectories etc. Please check for this. If this was the case, fixing the other sites will not require restoring the Default Web Site and you should be able to move those folders into other Website applications and remap Urls to make it all work again.

  2. To restore your Default Web Site, follow the step by step instructions on this site:

    How to Recreate Default Website in IIS 7 and above

    You will basically need to create a new website and run a adsutil.vbs command to change its ID to "1". And reset IIS.

    Note that after you follow the steps at the above linked article, you will need to manually add the Bindings as per Point #2 (Only Default Website) under "Resolution" at this link:

    Recreate HTTP and other Bindings on Default Website

Hope it helps!

share|improve this answer
add comment

If you open your c:\InetPub\History folder, you may be able to copy an older ApplicationHost.config from that location into System32\Inetsrv\Config.

This location is where the configuration backups are made - a check for changes is performed every 2 minutes, and if it's changed, up to 10 backups are kept. (default settings, configurable)

So if you haven't made more than 10 change sets, there's probably an older copy that might still work, from before you removed the Default Web Site, and this should get you back to that, possibly after a service restart.

share|improve this answer
    
it seems that the oldest isnt old enough :( –  darkdog Mar 27 '11 at 10:35
1  
Then you'll need to troubleshoot and fix it. Simplest suggestion is to remove the IP address binding and try just the host header (so all IPs, same host header), and see if that gets you any closer. –  TristanK Mar 27 '11 at 11:09
    
yes thats what i was thinking about, can you tell where i find this option to do this? –  darkdog Mar 27 '11 at 11:20
    
Right-click the site, Edit Bindings. –  TristanK Mar 27 '11 at 23:52
    
That error really looks like a Binding Issue to me as well, something else appears to be trying to use that port potentially. –  Brent Pabst Nov 17 '12 at 2:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.