Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Forgive me if I'm not too clear, I've been working for the last 18 hours. Here's my question:

I'm new to Server 2008. I'm attempting to set up a Department folder, with all departments listed beneath it. I want everyone to have read access on the Department folder itself so they can list it's contents, but then only the appropriate people have access to actually get into the subfolders. I set it up how I usually do in 2003: I set the permissions on the top-level Department folder to Everyone (Read, List Contents, Read and Execute). I then set the permissions on the sub folder to not inherit from the parent, and give only domain admins and the appropriate security group full control. The problem is, everyone who goes to the Dept folder sees nothing. It shows up empty.

Can someone give me an idea in Server 2008 R2 how the permissions for this scenario should look? Thanks!

share|improve this question

1 Answer 1

ABE is enabled by default on shared folders in W2K8, so users will only see folders within the share that they have access to. Have the users logged out and back in since you've added them to the security groups? If not, they need to do that.

http://technet.microsoft.com/en-us/library/dd772681(WS.10).aspx

share|improve this answer
    
Yes, they have logged out and in. The problem is, the subfolders are not visible to them. It just shows up as empty... –  Joe B. Mar 28 '11 at 1:19
    
The only reason I can think of for why they would be able to access the share but not see any of it's contents is ABE. Try adding a single user to the permissions of one of the folders and see if that user is able to see and access the folder. –  joeqwerty Mar 28 '11 at 11:37
    
It was indeed ABE! Thank you!! –  Joe B. Mar 28 '11 at 20:34
    
Glad to help. Don't forget to accept my answer. –  joeqwerty Mar 29 '11 at 16:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.