Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I inherited an Apache configuration with a piece I don't really understand. The directory path there is


And if you point the browser to


it actually shows the index.php file from the directory and not the root directory. Why would it be? Can there have been some config that had made the default be that / directory? Nothing under the root resolves anymore. How can I make things under root be recognized by the server again?

Thanks, Alex

share|improve this question
up vote 4 down vote accepted

For an Ubuntu system, the usual place you want to look is the /etc/apache2/sites-enabled directory. The files in there will define how you vhosts are configured. In particular check the DocumentRoot settings for you virtual hosts.

share|improve this answer

What is your 'DocumentRoot' set to in your httpd.conf?

It may be set to: DocumentRoot "/var/www/"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.