Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Can apache1 and apache2 install in the same server.?

share|improve this question
    
Try to be more explicit why you want to do this give us munch information you can without compromising your security. –  Gopoi Mar 29 '11 at 3:52

3 Answers 3

Yes, although it will take some work if you do it with a packaging manager. Best approach is likely to compile from source in this case, so you can control where everything goes with the --prefix arg to configure. When you start them you'll have to make sure they're listening on different ports, too.

There isn't any reason why you can't do it, you just need to make sure they're not going to step on each other.

share|improve this answer

I not sure to what you want to install both apache version on your server. It is like you want the brand new model of car and the old one too.

There is no reason you can not install it but there will be a problem if they try to serve on the same port (80) as on will block the other. But if you configure them on different port it will work. Again I don't know why you want to do this.

share|improve this answer

Yes you can, but you might run into conflicts between the two products. It would be better if you ran Apache 2.2 and Apache 1.3 on different machines, or different Virtual Machines if hardware is scarce.

  • To install Apache 2.2 on Ubuntu 10.x, follow the instructions in the Ubuntu Server Guide

  • Ubuntu 10.10 does not provides an Apache 1.3 package, but you can always install from the source code. To install Apache 1.3 from source, follow the instructions at http://httpd.apache.org/docs/1.3/install.html . If it works, compiling shouldn't be very difficult.

    • Keep in mind that Apache 1.3 has reached the End of Life, and is not supported anymore. As Apache 1.3 drifts further and further into memory, it will become less computable with modern operation systems. Apache 1.3 may require dependencies which are not provided by default.
  • As a distant third option, you could try Ubuntu 6.06 LTS (Server), which is supported until June 2011. It ships with Apache 1.3.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.