Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running into a bizarre issue with a router on my local university. There is one wireless router near the classroom where I have most of my classes that has a dhcp server running that gives out the self-assigned ip address that it's currently using for itself. (This router is broadcasting the same SSID as the rest of the campus routers) I use my laptop in class frequently since I do all my course work on it.

When my laptop is running Windows I just lose network connectivity for a minute or two whenever windows jumps to the signal from the bad router. Windows seems to realize something went horribly wrong and jumps back to the previous signal immediately. While annoying this is tolerable.

However when I'm running OSX the wireless driver stays locked on the signal from the bad router. I've been able to shake it from the signal after deleting the wireless network from my auto-join list, reconnecting and forcing a new ip address from the advanced network options. Sometimes this doesn't work and the only working solution is to find an ethernet jack and get a good ip address. When I finally get a good ip address from ANY source my wireless self-assigned ip issues disappear until the next time.

Asking the campus tech people to fix the router is pointless from my experiences with them. They still haven't fix many many other issues. Hacking into the router's configuration page is a bad idea because I might get expelled and I only have one semester to go before I graduate.

How can I prevent Windows and OSX from ever connecting to this router or at the very least get OSX to jump to a different signal when this happens?

share|improve this question
up vote 3 down vote accepted

If I'm reading the question correctly, you essentially want to force connect to a specific wireless access point.

The standard Airport Network interface doesn't have an option to connect based on MAC address but the program iStumbler does allow you to see all WAPs with common SSIDs, select the WAP and click "join". You can try using it to select the specific WAP and see if the underlying OS acknowledges the request or if it merely joins the default WAP with the same SSID.

share|improve this answer

All I would do is contact your campus support.

share|improve this answer

For clarification: The wireless router - does it have the same name as other wireless networks you connect to in the area?

If not you can tell OS X to stop connecting to that WAP:

Go to the Apple Menu and choose System Preferences, then click on the Network Preference Pane

If using Leopard (10.5):

  1. Click on your Airport connection and then press the Advanced button on the bottom right hand side of the window.
  2. Under the Airport tab you'll see a list of Preferred Networks, find the one in question that you are erroneously connecting to and press the '-' button below it. Then press OK, then press Apply. It will stop connecting to that particular WAP.

If using Tiger (10.4):

  1. Click on your Airport Connection and then press Configure at the bottom of the window.
  2. Select the Drop down menu and change it from Automatic to Preferred Networks, choose the offending WAP name and press the '-' below it.
share|improve this answer
"This router is broadcasting the same SSID as the rest of the campus routers" – epochwolf May 3 '09 at 17:32
If that is the case, then your best option is to try Michael Glenn's answer. – Chealion May 4 '09 at 17:32

I doubt you can do much about it, it's akin to a rogue AP - report it. If it doesn't lead anywhere, we would say "switch school" - but perhaps an easy workaround would be to unplug its power (or cut the power cord, it's not "hacking" per se is it ;)

Or you could hi-jack an IP address and set it manually, hoping to avoid a conflict...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.