Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying changed the "Search Settings" of a SharedServicesProvider so that I can change what kind of things can be searched in a SharePoint site, but I'm hitting a roadblock here.

For the default SSP, I can't get into the Shared Services Admin Site menu. of it, but I still have sufficient rights to go and modify any websites that use this application through the "Site Actions" tab on the top-right corner of the page.

When I go to make a new SSP, I am able to view the Shared Services Admin Site menu and add properties in the search engine, but I don't have sufficient rights to make changes to the "Advanced Search" menu of the new SSP.

So, what would be the easiest solution for me right now? Would it be easier for me to resolve the issue of why I can't view the Shared Services Admin Site menu, or to somehow give myself high enough rights to make changes to the new SSP?

share|improve this question

Can you try the following?

  1. Add yourself as farm administrator (people and groups section of CA)
  2. Create a new policy in CA and add yourself to that policy
  3. recover your farm admin account and try to log on with that account. See if you can access the SSP with that account (Last resort).

When you perform these steps please monitor the eventviewer and the SharePoint ULS logs on the SharePoint frontend box. They might give you additional info on what is going on.

Good luck and let me know how you go.

share|improve this answer
What kind of "policy" are you talking about? And, how do I add myself to it? – Liars_Paradox Mar 30 '11 at 19:59
Go to your central administration, find Policy for Web Application menu, select your SSP webapp and yourself there. This will "overwrite" your default security settings and should give rights to everything. – Mark van Lunenburg Apr 8 '11 at 11:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.