Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

This question already has an answer here:

I am on Windows Server 2008 R2, and disabled the enhanced security configuration for IE in server manager.

I have since upgraded to IE 9, and can no longer disable it.

It is set as disabled in server manager, yet it is still very much enabled as evidenced by the warning whenever I visit any site.

How can I actually disable this feature?

share|improve this question

marked as duplicate by mdpc, HopelessN00b Feb 24 at 10:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
could you provide some detail as to why you want to disable ESC? If you set it as disabled its possible that group policy has it enabled. –  Jim B Mar 29 '11 at 22:09
    
Disabling ESC in Windows is usually done in the add/remove windows components section of the Programs applet in Control Panel. Check there and see if IE9's installation re-installed it. –  Sean C. Mar 29 '11 at 23:01
    
I would just enable it in server manager, reboot the server, then disable it in server manager again. The IE9 install must have messed with your setting... –  charnley Mar 29 '11 at 23:13
    
@Jim, because it's more of a hindrance than a help. –  Jay White Mar 30 '11 at 0:04
    
@Sean, Everything I have read states that it should be enabled/disabled via server manager, and indeed I don't have a windows components section just a turn windows features on or off, which takes me to server manager @Charnly, first thing I tried, made no difference. –  Jay White Mar 30 '11 at 0:07

2 Answers 2

What I did was a reg-key that gets import as the user:

HKCU\Software\Microsoft\currentversion\internet settings\IEharden=0 (dword)
share|improve this answer

Did you try to save your settings again? I did (in Server Manager > Configure IE ESC > changed a radio button, changed it back to its original setting and hit OK), and it worked. No reboot was required.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.