Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am setting up CKAN, a pylons application according to these instructions: http://packages.python.org/ckan/deployment.html

But when I point to the server (no DNS setup yet) using IP or hostname, I only see apache's greeting page, sugesting the ckan app is not being loaded.

here is my mod_wsgi script:

import os
instance_dir = '/home/flavio/var/srvc/ckan.emap.fgv.br'
config_file = 'ckan.emap.fgv.br.ini'
pyenv_bin_dir = os.path.join(instance_dir, 'pyenv', 'bin')
activate_this = os.path.join(pyenv_bin_dir, 'activate_this.py')
execfile(activate_this, dict(__file__=activate_this))
from paste.deploy import loadapp
config_filepath = os.path.join(instance_dir, config_file)
from paste.script.util.logging_config import fileConfig
fileConfig(config_filepath)
application = loadapp('config:%s' % config_filepath)

here is my virtual host configuration:

<VirtualHost *:80>

ServerName dck093

ServerAlias dck093

WSGIScriptAlias / /home/flavio/var/srvc/ckan.emap.fgv.br/pyenv/bin/ckan.emap.fgv.br.py
# pass authorization info on (needed for rest api)
WSGIPassAuthorization On

ErrorLog /var/log/apache2/ckan.emap.fgv.br.error.log
CustomLog /var/log/apache2/ckan.emap.fgv.br.custom.log combined
<Directory /home/flavio/var/srvc/ckan.emap.fgv.br/pyenv/bin>
    Order deny,allow
    Allow from all
</Directory>
</VirtualHost>

I try to disable the 000-default site (with a2dissite), but that dind't help.After doing this I get an Internal server error page, but no log message. Can anyone point out what am I missing?

share|improve this question
    
I fixed a conflict that caused paste.deploy to fail importing, and now I am getting log messages (only INFO level ones, no errors) from the ckan app, meaning it is being loaded, but still can't load its page. –  fccoelho Mar 30 '11 at 13:58

2 Answers 2

if you are using IP to access the server, you should have ServerName or ServerAlias with the IP you are using or the virtualhost won't load.

share|improve this answer
    
I am using Hostname "dck093"; –  fccoelho Mar 30 '11 at 13:53

I found out that the debug feature of Pylons does not work with the default multi-process configuration of apache mod_wsgi.

see: http://stackoverflow.com/questions/5485790/mod-wsgi-pylons-ckan-installation-not-working

for more details.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.