Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have created a network installation point for Office 2010 ProPlus that contains two language packs — en-us, and cs-cz (Czech). I've also created an Office Customization File.

In my environment the OS language is English, however the locale is set to Czech. Office 2010 setup when run from the network installation point keeps running with Czech as the shell UI language. This behavior is documented.

I attempted to modify the config.xml file in the ProPlus.WW directory and add the following two lines:

<AddLanguage Id="en-us" ShellTransform="yes"/>
<AddLanguage Id="cs-cz" />

When I run setup.exe /adminfile myconfig.msp the setting is ignored. When I try to specify the config file on the command line like setup.exe /adminfile myconfig.msp /config ProPlus.WW\config.xml setup just displays the set of available command-line options, apparently not accepting these two parameters at once.

So, how to override this behavior and force English to be the default shell UI language?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Actually the problem is in the order of command line arguments. The /config argument must be specified first, before the /adminfile argument. Then the setup behaves as expected, installing the language marked with ShellTransform="yes" as the display language.

The command-line will look like this:

setup.exe /config ProPlus.WW\config.xml /adminfile myconfig.msp

Workaround used before: Most likely there's no way to do that which is a very, very annoying “feature”. The only workaround is:

  1. change Windows' locale in Regional settings to wanted primary language;
  2. install Office 2010;
  3. change back Windows' locale to the secondary language.
share|improve this answer
SETUP.EXE /CONFIG CONFIG.XML /ADMINFILE SOME-MSP.MSP

Take note: Office MUI product ID is OMUI.xx-xx. Visio = VISMUI.xx-xx and Project MUI = PMUI.xx-xx. It must be set in your first line: Configuration Product="OMUI.nl-nl"

example of customized CONFIG.XML:

<Configuration Product="OMUI.nl-nl">
<Display Level="none" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" />
<Logging Type="Verbose" Path="C:\TEMP" Template="MS-Office-OMUI.NL-NL.TXT" />
<AddLanguage Id="nl-nl" ShellTransform="yes"/>
<AddLanguage Id="nl-nl" />
<Setting Id="SETUP_REBOOT" Value="Never" />
</Configuration>
share|improve this answer
    
Thanks, I will try that as soon as I will be doing any installs. –  Ondrej Tucny Feb 9 '12 at 16:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.