Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hey everyone. I am trying to setup a slew of VM's for testing out a bunch of routing software packages like m0n0wall, pfsense, endian, vyetta, and more. I have a beefy vm server with 2 onboard NIC's and 1 Quad intel card. I have Vmware server 2 running on this box for my virtual host.

So far I have a VM of endian running and I have the following virtual network info:

VMnet2 (Bridged) - Bridged to Intel PRO/1000 GT Quad Port Server Adapter #1 VMnet3 (Bridged) - Bridged to Intel PRO/1000 GT Quad Port Server Adapter #2 VMnet4 (Bridged) - Bridged to Intel PRO/1000 GT Quad Port Server Adapter #3 VMnet5 (Bridged) - Bridged to Intel PRO/1000 GT Quad Port Server Adapter #4

All are said to have a subnet of 255.255.255.255, but they are bridged, so they get whatever is on the hard wire I believe.

Next, in the endian VM, I have 4 network adapters which are VMnet2, 3, 4, & 5.

I'm running all of this on an ATT U-verse connection and I've set the VMnet5 NIC to DMZ+ per the instructions for my ISP. In the uverse router, I can see from the MAC address that the hardware NIC of Adapter #4 is in fact assigned the public IP for my connection, but inside the virtual machine the NIC is being given a private DHCP ip from the uverse DHCP server (which cannot be shut off, but doesnt need to be since DMZ+ is giving the IP out directly.)

I have done a few things here. One is, I've gone into Endian and spoofed the hardware NIC's MAC address at which point endian did receive the correct public IP address. but when I try to access a webpage via the LAN (which is fed by VMnet2 (Adapter #1) I get connection reset via my browser and I cannot browse any pages. I can however, ping google.com, etc.

Has anyone tried setting up a virtual router like this before? I'd like to be able to switch between the routers at will for testing purposes.

share|improve this question
add comment

1 Answer

It's tough to tell from this whether your problems are due to virtualizing the endian setup or not. One way to find out would be to install endian directly on the host hardware (you could swap out the hard drive to avoid reinstalling VMWare later).

We've been running several (mostly pfSense) routers as VMs with bridged host interfaces under KVM for some time and it has worked swimmingly. We've never had to spoof the host MAC to get any of these to work, though if you rely on a DHCP server that filters by MAC address this may be necessary.

One issue we did have to work through involved configuring iptables on the host to allow forwarding to the guest IPs -- not sure if there is a corollary for your VMWare host but it may be worth looking at.

share|improve this answer
    
nedm, thanks for the reply. I think i forgot to give one piece of info. When I set the hardware nic as the DMZ+, i'm doing so through a web interface on the uverse modem and it is forcing my to choose the host name (useless since I have 4 nics on the same machine) or give it an IP. So based on the IP of that NIC, the modem pulls the MAC address from the hardware NIC. I wonder if I am able to give it the MAC for the virtual NIC that it would work correctly? But sadly, I dont see a way to add a MAC, only a host name or IP. I will try a pfsense VM next. –  Cybertron Mar 31 '11 at 0:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.