Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting the following error when trying view my freshly deployed application on IIS 7.0 on a Windows Server Standard server with Service Pack 2:

HTTP Error 404.2 - Not Found The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server.

Error Code 0x800704ec

I've deployed this application successfully on my own desktop PC.

To my knowledge, I am not using either ISAPI or CGI.

I get this even when requesting a plain and simple ASPX page.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

An ASPX page isn't plain and simple - it relies on an ISAPI handler, at least when the App Pool is in Classic mode. The ASPX extension is mapped to the ASP.Net ISAPI via ISAPImodule, which doesn't sound like it's broken, but it does sound like a server admin has turned off the ASP.Net ISAPI support.

This suggests the ASP.Net configuration has changed since it was installed (assuming ASP.Net is installed).

To investigate, open up the Web Server level's ISAPI and CGI Restrictions interface, and you should see at least:

  • ASP.NET v2.0.50727
  • %windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll

And if it's a 64 bit server

  • ASP.NET v2.0.50727
  • %windir%\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll

If that's not the case, or they're prohibited, you need to allow those DLLs in those paths to get ASP.Net to execute - compare the server settings for this (and your application pool mode) with your desktop computer.

share|improve this answer
    
I don't have "ISAPI and CGI Restrictions" in the Features section of my IIS. I have "CGI" and I have "ISAPI Filters". And both "ISAPI Extensions" and "ISAPI Filters" role services are installed. I've tried integrated mode and it seems to have worked, but why do I not have that interface? –  Jordan Mar 31 '11 at 13:25
    
You should - it's at the server level, not the Site? –  TristanK Apr 1 '11 at 0:31
    
Oh. I mean, April Fools! That was an April Fools comment!... no, no it wasn't. :( Thanks. –  Jordan Apr 1 '11 at 13:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.