Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My haproxy.cfg has a frontend which then redirects to a bunch of backends,

here is a sample backend (note that connections into this have already been through stunnel to rip out SSL:

backend thenameofit        
reqadd          X-Forwarded-Proto:\ https
reqadd          FRONT_END_HTTPS:\ on
server myserver1 serverhostnamex:80 weight 1 maxconn 5000 check
server myserver2 serverhostnamey:80 weight 1 maxconn 5000 check
appsession ASP.NET_SessionId len 100 timeout 3h

I'm sure I'm simply missing a setting somewhere, but I must be missing it when reading the config documentation.

I'm using HAProxy 1.4.13.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You also need to use "cookie ASP.NET_SessionID prefix".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.