Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm within a private network and I know what the address and port of the proxy are (becuase I have set it in Firefox), but I need to connect to an external Virtual Machine through Putty.

So the steps that I have followed in order to accomplish the task are:

  1. Set the IP address in Putty
  2. Add the private key file for authentication (I think this is not important for the problem)
  3. Set the proxy address and port in the Connection > Proxy option of Putty

I'm not able to connect, what can be the possible problem? Am I following the right procedure?

share|improve this question
1  
Does the proxy accept CONNECT method? It is used for https connects. Try to set your SSH daemon with port 443 and retry. May be the proxy blocks all CONNECTs not to https port. –  HUB Mar 31 '11 at 9:28
    
I don't know if the proxy accept CONNECT method. Unfortunately I'm not a system administrator but a developer, however I have setted the port 443 on putty with the current address of the proxy but equally can not establish a connection –  carlo Mar 31 '11 at 9:33
    
I'm using a standard openssh client with Linux, so I'm not very failiar with putty. But, may be there are some logs? And log verbosity options? –  HUB Mar 31 '11 at 9:36
    
Are you using PuTTY to talk to a web server, or are you trying to log in with SSH somewhere? –  MattBianco Mar 31 '11 at 12:13

1 Answer 1

up vote 1 down vote accepted

Probably your proxy does not allows to connect to port 22 (CONNECT requests should be allowed, usually they are allowed only for https ports). Try to change remote ssh server port to 443.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.