Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

A Windows Server 2008 R2 (SP1) server is configured with the following IPs (in order):

x.x.x.50
x.x.x.40
x.x.x.41
x.x.x.42

For DNS requests, it appears to be using x.x.x.40 as its outbound IP, but when an application makes a request it uses x.x.x.50. This seems unpredictable and we're trying to create routing and firewall rules in our switches and firewalls, but aren't sure how it's determined which IP is used in what context.

Any insight would be greatly appreciated.

share|improve this question
    
I'm sorry - neither 44 nor 51 is in your list of IPs? Can you say what application, though I do not know if that matters? –  Jeremy Mar 31 '11 at 19:05
    
Corrected the question with correct IPs - It's a web application running in IIS (.NET 4 Integrated Pipeline mode). –  lukiffer Mar 31 '11 at 19:07
    
The DNS thing is puzzling. I believe you can affect the order of the network connections by going into Control Panel -> Network and Internet -> Network Connections -> Hit Alt -> Advanced. Maybe try poking around there. Sorry not a real answer. –  Jeremy Mar 31 '11 at 19:12
    
Is IIS responding to requests on all IPs? –  Jeremy Mar 31 '11 at 19:19
    
The web app is configured to a specific IP (x.x.x.42), but is using .50 to make outbound requests. Both DNS and Kerberos are going outbound from .40. Under advanced, I can control which protocol gets priority, but not which address. –  lukiffer Mar 31 '11 at 19:32

2 Answers 2

up vote 1 down vote accepted

Take a look at the following article.

share|improve this answer

One thing that comes to mind is going into the advanced TCP properties, click the DNS tab and uncheck 'register this connection's address in DNS' doing this will then require you to go into your DNS server and selectively remote the ones you don't want it to respond on. You may also need to do an ipconfig /flushdns and clear cache.

Let me know if that does the trick, good luck!

share|improve this answer
    
This doesn't appear to affect the IP it uses for outbound communications, only the IPs that other servers use to connect to it. –  lukiffer Mar 31 '11 at 19:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.