Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to set up a new project in Eclipse, but it gives me an error saying that the directory where I am trying to set up the project is read-only.

Here is the error: Parent of resource: /path/to/project/.project is marked as read-only. (Permission denied)

I do know the password for the machine to get root permissions. How can I use it to give Eclipse complete editing permissions so that this error does not happen?

Thanks, Alex

share|improve this question
up vote 3 down vote accepted

Assuming you're logging in as a non-root user myuser, simply run:

sudo chown -R myuser:myuser /path/to/project

which will make you the owner of that directory (and subdirectories).

share|improve this answer
That totally worked!!! :) Thank you! – Genadinik Mar 31 '11 at 20:15
Thanks a lot buddy! It solved the problem I was trying to get rid from 15 days – Deepika Rajani Apr 5 at 5:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.