Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running KVM on top of Ubuntu 10.10 Server

I can create VM's (Virtual Machine) and network interfaces fine but I cannot seem to add more than three network interfaces. As soon as I have a VM with four network interfaces it gets stuck on startup at the starting SeaBIOS page with this message:

Starting SeaBIOS (version pre-0.6.1-20100702_143500-palmer)

So far I've verified this with two VM's, a Ubuntu 10.10 desktop and a Vyatta router. The specific network hardware I assign to the VM's doesn't seem to matter. I'm trying to have one bridged interface and three private networks using Vyatta to route between them.

Does anyone know why I can't run a VM with more than three network interfaces?

Edit: Additionally the KVM thread responsible for the specific VM hangs using ~100% CPU (i.e. one core). Here's the command for the process that is hanging:

/usr/bin/kvm -S -M pc-0.12 -enable-kvm -m 512 -smp 1,sockets=1,cores=1,threads=1 -name vyatta -uuid 6dff7c94-6810-423e-5fea-fec10da0e9b7 -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/vyatta.monitor,server,nowait -mon chardev=monitor,mode=readline -rtc base=utc -boot c -drive file=/home/rams/virtual-machines/vyatta.img,if=none,id=drive-ide0-0-0,boot=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -device rtl8139,vlan=0,id=net0,mac=00:54:00:be:cc:4b,bus=pci.0,addr=0x3 -net tap,fd=97,vlan=0,name=hostnet0 -device rtl8139,vlan=1,id=net1,mac=52:54:00:da:59:ed,bus=pci.0,addr=0x5 -net tap,fd=98,vlan=1,name=hostnet1 -device rtl8139,vlan=2,id=net2,mac=52:54:00:ce:22:b6,bus=pci.0,addr=0x6 -net tap,fd=99,vlan=2,name=hostnet2 -device rtl8139,vlan=3,id=net3,mac=52:54:00:1e:bc:46,bus=pci.0,addr=0x7 -net tap,fd=101,vlan=3,name=hostnet3 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -vnc -k en-us -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x4

Edit: I've also found an error in dmesg that might be related (it also shows up when running virtd in verbose mode):

14:47:24.399: warning : qemudParsePCIDeviceStrs:1422 : Unexpected exit status '1', qemu probably failed

I've also tried disabling app armor but that doesn't seem to make a difference.

share|improve this question
Strange I just fired up a VM with 4 NIC's on my laptop running Ubuntu 10.10 64bit. The VM in question was running Ubuntu 10.04 Server 64bit. – 3dinfluence Apr 2 '11 at 3:20
I can start a 4 interface kvm virtual machine using Proxmox, no problems. – Antonius Bloch Apr 11 '11 at 21:11
Does the VM still hang if you have 4 private networks instead of 3 private and 1 bridged? – sciurus Apr 11 '11 at 21:31
@Antonius Bloch, are you using Ubuntu? – Jason Axelson Apr 11 '11 at 21:42
@sciurus Yes it does still hang in the same way – Jason Axelson Apr 11 '11 at 21:43

Strange, I just started a VM on Fedora 14, with 4 NICs attached.

share|improve this answer
Maybe Ubuntu doesn't support KVM as well as Redhat/Fedora? – Jason Axelson Apr 1 '11 at 21:30
That's not a maybe. If you go through the kvm threads in this site, you'll see loads of issues with Ubuntu, especially v10 – dyasny Jun 15 '12 at 11:07

I don't think it's the number of NICs -- are you using libvirt to create guests? Looks like it's using RealTek (rtl8139) qemu drivers, which have sometimes been known to cause freezes or other issues under KVM. I would try switching them to e1000 or virtio.

virsh dumpxml vm1 > vm1definition.xml
virsh destroy vm1

Edit the xml file and replace rtl8139 in each NIC definition with virtio or e1000

virsh create vm1definition.xml
share|improve this answer
Sorry, I still get the same issue. I did notice a warning in dmesg but it might not be important (detail in main post) – Jason Axelson Apr 2 '11 at 0:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.