Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi I have created an amazon ec2 instance and now I need to deploy my java/j2ee based web app. I have apache tomcat6 running. I am managing the server via ssh in terminal. I need to copy war files to the server through how do I do that. I am newbie kindly help m

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Just use SCP.

share|improve this answer
    
I tried rsync I used this command rsync -avz filename.war instance_key.pem ubuntu@xx.xx.xxx.xx:/var/lib/tomcat6/webapps and I also tried rync -avz filename.war ubuntu@xx.xx.xxx.xx:/var/lib/tomcat6/webapps from both remote terminal and local terminal but its not working I am getting an error which says permission denied (public key) –  Jeevan Dongre Apr 1 '11 at 11:10
1  
This may help; troy.jdmz.net/rsync/index.html –  Chopper3 Apr 1 '11 at 11:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.