Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So I have a bit of a weird thing here. I was testing Forefront with MOM 2005 and WSUS and ran into a problem. One of the computers I was testing with had to be re-imaged due to a failed SP update. Because of this, I had to delete it from the domain, and not unjoin it.

When I re-imaged the machine and joined it to the domain, I used the same hostname (we use the service tag as the hostname). Apparently, WSUS did not like this as it thought it was already current with updates. I changed the hostname in order for WSUS to push the updates to the client (which also included FF and MOM 2005) and everything seemed fine. That is, until I changed the hostname back to our standard.

The hostname change does not reflect in the MOM console, and I can't seem to get it to. I've tried rediscovering attributes, I tried unjoining and rejoining the domain. Everything short of uninstalling the agent and reinstalling it. Is that really the route I have to go, when I need to rename a computer?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Delete the system from the MOM administration console.

  1. Go to MOM administrator console and select Agent Managed computers
  2. Select the computer on the right-hand side and click "Force to unmanaged Management node" and click Yes.
  3. Go to Agentless Managed computers and right-click the computer and select Delete.

On the client

  1. Stop the MOM service
  2. Clear the cache (Delete the directory c:\documents and settings\all users\App Data\Local Settings\Microsoft\Microsoft Operations Manager\YOURMGMTGROUP in XP or C:\Users\All Users\Microsoft\Microsoft Operations Manager\YOURMGMTGROUP in Win7)
  3. Restart the agent. It should pop into Pending Actions with the new name
  4. Approve it under Pending Actions.

I've done the above, and it works. The only weird thing is that it didn't pull the AD description of the client computer, it's just blank, but that's a different problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.