Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

on Ubuntu, I have SVN setup. I have created a repository and imported the files. On the same machine, I can checkout via file://

Works:

svn checkout  file:///svn/siteinabox

Doesn;t work (tried from the same machine):

svn checkout  svn://localhost/siteinabox  
svn: URL 'svn://localhost/siteinabox' doesn't exist

Ultimately my aim is to access the repo from a remote machine. Currently, it gives the same error from remote machine.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Found the answer: I had started svnserve like this:

svnserve -d -r /svn/project

instead it should have been like this

svnserve -d -r /svn
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.