Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting an issue when trying to send out email on 465 secure SMTP with a Postfix + Courier with MySQL virtual users. I am able to connect with IMAP secure and download, and I can also send mail on Port 25 unsecured. I am trying to use SASL for the outgoing. When I try to telnet port 465 its refused. When I try to send a message I get this in the /var/log/mail.log

Apr 2 00:24:34 Lucid postfix/smtpd[3714]: connect from pool-74-111-178-60.pitbpa.fios.verizon.net[74.111.178.60]
Apr 2 00:24:34 Lucid postfix/smtpd[3714]: warning: SASL authentication problem: unknown password verifier
Apr 2 00:24:34 Lucid postfix/smtpd[3714]: warning: SASL authentication failure: Password verification failed
Apr 2 00:24:34 Lucid postfix/smtpd[3714]: warning: pool-74-111-178-60.pitbpa.fios.verizon.net[74.111.178.60]: SASL PLAIN authentication failed: no mechanism available
Apr 2 00:24:34 Lucid postfix/smtpd[3714]: warning: SASL authentication problem: unknown password verifier
Apr 2 00:24:34 Lucid postfix/smtpd[3714]: warning: pool-74-111-178-60.pitbpa.fios.verizon.net[74.111.178.60]: SASL LOGIN authentication failed: no mechanism available
Apr 2 00:24:35 Lucid postfix/smtpd[3714]: disconnect from pool-74-111-178-60.pitbpa.fios.verizon.net[74.111.178.60]

/etc/postfix/sasl/smtpd.conf - http://74.111.178.60/random/smtpd.conf

/etc/postfix/main.cf - http://74.111.178.60/random/main.cf

share|improve this question
    
/etc/postfix/master.cf - 74.111.178.60/random/master.cf /etc/default/saslauthd - 74.111.178.60/random/saslauthd /etc/pam.d/smtp - 74.111.178.60/random/smtp –  Shane Apr 2 '11 at 0:50

1 Answer 1

Check MECHANISMS in your random/smtpd.conf file first. On my OS it's /etc/default/saslauthd.

I use PAM authentication, test it first with a login from /etc/passwd as it seems to be set to PAM. Also to keep it simple you can try using SASL over port 25, it's is pretty good too.

Create this directory if it doesn't exist: /var/spool/postfix/var/run/saslauthd/ for spooling.

My /etc/default/saslauthd looks like this. Hopefully your error is as simple as changing MECHANISMS="pam" to mysql or similar:

START=yes

DESC="SASL Authentication Daemon"

NAME="saslauthd"

MECHANISMS="pam"

MECH_OPTIONS=""

THREADS=5

OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"

share|improve this answer
    
Even with a different flavour of OS I'd still try PAM or similar authentication first. –  Jonathan Ross Apr 2 '11 at 6:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.