Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using lighttpd with fastcgi, just enabled mod_compress but its not writing anything in the directory that i have set i.e. /tmp/lighttpdcompress/

I've given its ownership to lighttpd and also set 777 permissions. The folder stays empty after I request a page, and if I check in FireBug, it doesn't say that its gzip

However I do get this in the log:

2011-04-02 17:33:42: (response.c.719) -- handling subrequest
2011-04-02 17:33:42: (response.c.720) Path         : /srv/www/lighttpd/v0/web/index.php
2011-04-02 17:33:42: (mod_access.c.135) -- mod_access_uri_handler called
2011-04-02 17:33:42: (mod_compress.c.683) -- handling file as static file
2011-04-02 17:33:42: (mod_fastcgi.c.3703) handling it in mod_fastcgi
share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Ok guys, this was a noob mistake :P

In PHP.ini I had:

zlib.output_compression = Off
share|improve this answer
add comment

Have you checked the perimisions of the directories in the path?, maybe lighttpd has permisions on that directory, but it can't reach it.

Also mabye you have to restart it to make it understand the change on the configuration.

And last, well, giving 777 permisions is not very safe, if it's the owner, with 700 would be enought, unless you want some other user access that directory.

share|improve this answer
    
Yes, /tmp also has 777 permissions. I set 777 permissions to check if that was the problem. Well yeah I've restarted it many times till now. If it helps, I also have mod_expire enabled, and I'm using APC accelerator –  gX01 Apr 3 '11 at 15:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.