Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to ramp up knowledge on SharePoint deployment and usage (never did before), due to a direction to use SharePoint 2010 as a repository platform (wiki format) for our customer's infrastructure documentation.

In my test virtual server, a new site of Enterprise wiki template was setup. Went into Site Actions > Manage Site Features to activate Wiki Page Home Page. The default sub-web then went from /Pages to /SitePages and looks like the default Team template. The odd thing is the Site Actions is missing the New Page option. My colleague does not understand why this is the case, as it ought to be there. The original /Pages sub-web does have the option.

enter image description here

What conditions are in play that influences the appearance of that option?

UPDATE

Another phenomenon observed is in the Site Actions > View All Site Content view, the wiki document libraries listed in the grid will have their hyperlink (e.g. "Site Pages") lead straight to the direct default page. It would not show its own table listing of pages under that document library, unlike the original Pages document library, which expectedly show up as a listing. I wonder if this hints to any problems.

share|improve this question
    
Weird ... should be there. Just checked it on a default teamsite. Can you try typing in the double [[ Does that give you anything? –  Mark van Lunenburg Apr 4 '11 at 9:32
    
Not Team site; try creating an Enterprise wiki site, then activate the Wiki page Home page feature. –  icelava Apr 4 '11 at 10:02

2 Answers 2

You can fix the second issue by changing SPList.RootFolder.WelcomePage value from Homes.aspx to Forms\AllItems.aspx. This worked for me.

share|improve this answer

I ran into this issue this morning. We are running a new SharePoint 2010 farm with heavily customized master page and page layouts. Each subsite was created as a Wiki Site and page creation was working fine using the [[]] notation. However I was the only person seeing the 'New Page' option in the Site Actions menu, nobody else could see it. I resolved it by doing the following:

  1. Activating the Wiki Site Feature
  2. De-activating the Wiki Site Feature

I had to de-activate the wiki site feature because it creates the SitePages library and then hijacks the page layout. I found that after de-activating the feature, the New Page option was still visible to my users and the new pages were created in the correct /Pages/ library with our custom page layouts.

share|improve this answer
    
I had the same problem, but on a Publishing Site. The De-activate/Activate trick did it for me, but instead of the Wiki Site Feature, I did it with the SharePoint Server Publishing Site Feature. –  user132793 Aug 20 '12 at 12:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.