Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using a Windows 2003 Server install as my software development workstation. Every now and then I'll get application crashes and sometimes I don't get notified of the crashes at all by the Error Reporting Service, at least not until I re-log on to Windows. I've been googling for a way to disable this and the only thing I've managed to find is the name of the feature (Queued Error Reporting) and it's justification (which makes a lot of sense in a server environment, but it's useless and annoying on a dev machine).

Is there any way to disable this behavior and make it act more like the traditional Workstation versions of Windows handle it (show error at the moment, not at next boot)?

Using Windows 2003 Standard SP2, and I have the "Disable Error Reporting" option set.

Edit to clarify: This is a development machine. I want to be able to disable reporting errors on startup and make them appear when they happen. It's very annoying to launch an app 10 times and not know why it isn't showing up, only to find out later after logging on that it was crashing. I just want this aspect of Win Server to behave like a regular Windows install. Just so people stop posting the obvious, here's the settings dialog:

Error Reporting Configuration

share|improve this question
    
You've asked it to notify you when critical errors occur..? Is that not the notification you're receiving? Have you tried unchecking that box? –  Jaymz Apr 5 '11 at 15:11
    
I think you answered your own question in your first sentence. Why are you using a server as a workstation? –  Bryan Apr 5 '11 at 15:37
    
Corporate environment. They want us developing on the same platform as production to avoid potential differences in OS'es. This isn't completely unheard of. Everywhere I've worked does this. Not that I'm a fan of it, though, but I have no control over it. –  enriquein Apr 6 '11 at 12:42
    
@Jaymz87 - If I turn it off I don't get notified ever of app crashes. I'm pretty sure that if what I'm asking for is configurable, it wouldn't be configured in this dialog window. I only posted it so that the people who have never worked on server edition can see that this part is configured properly. –  enriquein Apr 6 '11 at 12:44

2 Answers 2

Since you are receiving these error reports for only your developement app, you can turn off reporting for that specific program.

Enable error reporting, then click on Choose Programs. Add your development app to the list "Do not report errors for these programs".

share|improve this answer
    
No, that's not what I meant. It's a development machine, and stuff crashes here and there. It's just annoying to launch an app 10 times and not know why it won't show up, only to find out 3 days later after logging on again that it was crashing over and over. Will edit question to clarify. –  enriquein Apr 4 '11 at 19:50
  • Control Panel
  • System
  • Advanced tab.
  • Error Reporting

Set your options as desired.

share|improve this answer
    
Added the settings dialog to the question. As you can see, there's no option for "show errors when they occur instead of on next log on". –  enriquein Apr 5 '11 at 15:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.