Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Okay, I am trying to get the group policy to work where after logon the user gets a message prompt. I set the GP, but the message doesn't show.

I first searched and seen another post with the same issue a year ago, but not sure it was ever resolved or 100% answered. So I would like to post this question again.

I did a GPresult and see the proper policy is being enforced.

I don't know why it isn't working. Any other suggestions.

share|improve this question
2  
Just to verify, you're setting the following policy, correct? Computer Configuration - Policies - Windows Settings - Security Settings - Local Policies Security Options :: Interactive logon: Message text for users attempting to log on –  pk. Apr 4 '11 at 17:54
    
Yes, that is the correct one, well at least the one I am editing. –  jherlitz Apr 4 '11 at 19:02
    
@pk That policy will display a message before the user logon. There is not a pre-existing policy for displaying a message after logon. –  jscott Apr 4 '11 at 19:22
    
okay, that should still be okay. How come I don't see the message then? –  jherlitz Apr 4 '11 at 19:23
add comment

2 Answers

Figured this out. I was doing everything right, HOWEVER you need to specify the Message title for user attempting to log on as well! As soon as I enabled that, it worked.

share|improve this answer
    
Man, I even thought about suggesting that (since I checked our policy and that's how we had it configured), but I figured that would be a stupid design so I stayed silent. Now I know. –  pk. Apr 7 '11 at 16:27
add comment

Computer Configuration - Policies - Windows Settings - Security Settings - Local Policies Security Options :: Interactive logon: Message text for users attempting to log on

That policy message shows up after you hit Control - Alt - Delete to start logging in. To show a message after login I would imagine you would need to include that message with your login script.

share|improve this answer
    
really? That would be cool, and I would be happy with that. I just can't figure out why it isn't working. –  jherlitz Apr 4 '11 at 19:25
    
Try rebooting the machine after running "gpupdate /force" in the command prompt –  xeon Apr 4 '11 at 19:57
    
already tried that a few times. –  jherlitz Apr 4 '11 at 19:59
    
The computer in an OU where the policy is enforced? You can try manually setting the computer to read or enforce the policy in GP management. –  xeon Apr 4 '11 at 20:09
    
The domain policy might be overwriting your set policy BTW. Might want to check do not inherit. –  xeon Apr 4 '11 at 20:16
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.