Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i've setup a SSL certificate to use in a website i'm working on. The problem is that when "Require SSL" is checked in iis, i get the following error while trying to access the site:

403 - Forbidden: Access is denied. You do not have permission to view this directory or page using the credentials that you supplied.

If that checkbox is not checked, the site works fine (i'm not sure why, but i can even access it through SSL).

Not sure if it makes any difference, but my company has an ISA server that we use as a proxy / firewall.

Thanks, Gonzalo

share|improve this question

3 Answers 3

The Require SSL checkbox should have 3-option radio button for "Client Certificates". What have you selected there? If you have it set to Require, then it will require client authentication and if you don't specify a client certificate, it will give you the access denied. If you set it to ignore or accept, it will not be a fatal error if you don't specify client certificate.

share|improve this answer

IIS is not gentle about its SSL requirements. When a request comes in via a non-SSL connection for an SSL-required resource, it returns a 403 instead of, say, redirecting you to the SSL page.

It should let you in if you manually change the address in the bar to https://

share|improve this answer
    
The problem happens accessing with SSL, with "Require SSL" checked. –  Gonzalo Apr 4 '11 at 19:01

I recommend just removing port 80, only run over port 443 with SSL and the appropriate binding in place. You don't want to require SSL as that is for client side connections.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.