Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'll start with the specs:

Intel S5500BC Board
2x Intel Xeon E5506 Processors
8x Corsair CM72DD2G1113 RAM
1x Western Digital Caviar Green WD10EADS-00P8B0 HDD
(really 4x in RAID-10 but I destroyed the RAID thinking that was part of the issue)
Thermaltake ToughPower 1200W Power Supply
Running Windows Server 2008 R2, and WAMP 2.0i

The issue is that the machine will hang seemingly randomly. I first thought it was a HDD R/W issue because it happened a lot when I accessed/saved files, but it also hangs at other times, such as when I switch between program windows or even tabs within a window; but it doesn't do it every single time. Also, when it hangs, it hangs for sometimes more than a full minute.

I have run Memtest on the RAM (each individual stick and together), run checkdisk on each of the hard drives, updated all BIOS/Firmware/Drivers available, and ran BurninTest, all without a single error/warning.

One thing I should point out (something I was unaware of when I purchased parts) is that the Xeon processors throttle the RAM speed down to 800.

Any suggestions would be greatly appreciated.

share|improve this question
Have you checked the system error logs? – Joseph Kern Apr 4 '11 at 20:35
Hangs how? Can you still ping it? Definitely agree with Joseph Kern, run eventvwr.msc and look at the system log. Is Windows Update fully updated? (Could replace outdated drivers like what might come in the box for the RAID controller). Finally, have you considered applying SP1 for Server 2008 R2? It came out just last month I believe. – Mark Allen Apr 4 '11 at 20:43
Hangs as in freezes the window I'm currently in. When I try to leave the window, it doesn't let me at first, then the application goes into (Not Responding) and I can minimize the window, but I can't do anything else. It just doesn't respond to anything I do (such as open My Computer) until it handles whatever error is occurring. I have traced through the event viewer, as well as using processhacker and procmon to try to trace to the root of the problem. I have never been able to trace it back to a common file/task/process/service. Also, the machine is on an intranet with no outside access. – Chris Apr 4 '11 at 20:57
So I cannot use MS Update to update anything. But I have downloaded and tried both the latest RAID and AHCI drivers available to no avail, as well as BIOS/Firmware/everything else available. – Chris Apr 4 '11 at 21:01
My instinct is the CPU, try to stress the CPU with apps such as Prime95 and how the system handles it. Another thing I would try is to install Windows Server 2003 just for kicks to see if issue still occurs. Reset your Mobo to factory settings and then try to play with the processor options. – ToastMan Apr 4 '11 at 21:14

I have exactly same issue, and I confirm it's the HDD problem. As I switched to another HDD with a partition copy to migrate the OS, and all random freeze are solved.

backup your data and use the official site tools to check your disk life information...

unfortunately, Western digital does not provide any firmware update at all.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.