Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Terminal Services user who is getting the error below when they try to RDP from a new PC that I have moved them to. We have 4 other TS users, neither of whom are having any problem connecting.

"The remote computer disconnected the session because of an error in the licensing protocol

Please try connecting to the remote computer again or contact your server administrator."

I tried deleting the license keys from here on the client machine: HKEY_LOCAL_MACHINE\Software\Microsoft\MSLicensing. But this hasn't worked.

share|improve this question

It turned out to be a licensing issue. TS was set up with a per device license instead of a per user licence. In the end I had to swap an another PC that we still had a license for.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.