Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm not sure I can do what I want to do but here goes...

I have the following 2 websites setup on IIS 7 with the bindings specified

  • Production Web Site Bindings:

    • http / www.mydomain.com / 80
    • https / www.mydomain.com / 443
  • Staging Web Site Bindings:

    • http / sub1.mydomain.com / 80
    • https / sub1.mydomain.com / 443

I have a UC (SAN) SSL Certificate which covers all the domains. And I used the * friendly name trick when installing the cert to allow me to specify the bindings for the https.

Problem is when I visit https://sub1.domain.com I am seeing the Production website not the site on the staging.

As you can probably see I am having to use one server to managing a staging/testing site and the actually production site. Not ideal I know.

anyone know if what I'm doing is achievable?

Thanks!

share|improve this question

2 Answers 2

up vote 0 down vote accepted

If you are performing the configuration via the IIS management console UI, that will not work. You have to use the appcmd command-line utility.

http://www.sslshopper.com/article-ssl-host-headers-in-iis-7.html

share|improve this answer
    
Thanks I'll give this a try today! –  jryan Apr 7 '11 at 10:49

As well you might be able to add second IP to the server and configure the sub1 site to use it.

share|improve this answer
    
thanks, but I'm going to have alot of subdomains (one per client) so I don't really want to have to use different ips per client. –  jryan Apr 7 '11 at 10:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.