Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Pardon my server noobery. I have several sites hosted by AFMU. I can FTP with all of them and until recently was able to log into the cPanels for each of them with the same credentials used for their respective FTP logins. But now the cPanel logins all fail.

I checked with the host admin and they said my IP address was not blocked and, if it makes any difference, at the time, I was using some PHP to create and test some MySQL databases and was blocked from creating more once my hosting package's limit was reached, but I doubt this would lock me out of cPanel.

I've submitted support tickets to their admin and they seem to still be looking into it, but does anyone know what could be causing this and what I could tell them to look for?

Many thanks.

share|improve this question

closed as off-topic by Jenny D, Bryan, mdpc, Ladadadada, Michael Hampton Jun 28 '13 at 19:53

  • This question does not appear to be about professional server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

4  
This question appears to be off-topic because it concerns the use of shared web hosting by end users or resellers, rather than the administration of web hosting. –  Jenny D Jun 28 '13 at 9:33
add comment

2 Answers

up vote 1 down vote accepted

Whilst the two systems share the same login credentials there are a number of individual files and authentication settings. If you have access to Web Host Manager, try suspending and unsuspending the account to synchronise the credentials. If you normally access CPanel via the domain name (domain.com/cpanel) try pinging the domain name, obtain it's IP address and login through that instead to see if this makes any difference.

share|improve this answer
    
Interesting. A very temporary fix! Visiting "IP.ADDRESS.IP.ADDRESS/cpanel" automatically logged me in using old stored credentials in my browser (Safari). However, the admin said the password had been reset. I logged out and tried to log back in with both the old and new credentials and it no longer worked for either. So the second part of your answer helped for a second. Haha. I tried the WHM login and it failed for both old and new credentials as well... –  Old McStopher Apr 5 '11 at 20:17
    
Bizarre. It seems to be a problem with Safari. I've tried in Firefox and the old credentials work. But this creates two new mysteries: Why Safari? And why does the host think they've reset the password but the old one still works? –  Old McStopher Apr 5 '11 at 20:23
1  
Could be related to an SSL certificate, or your provider may be using a proxy redirect script which is causing issues. Unfortunately you really need root access otherwise it's a guessing game, but Firefox/Safari do treat the above situations differently, keep us updated when the provider gets back to you. –  Richard Apr 5 '11 at 20:32
    
Well, they wrote back that it was a browser issue and it seems they may have been right. I deleted the saved password entry in Keychain (which Safari pulls from) and retried. That did the trick. I'll post this as an answer for the SF community's benefit. –  Old McStopher Apr 5 '11 at 20:39
add comment

It turns out, this was a browser-specific issue. Accessing the cpanel from Firefox worked, but Safari did not. I deleted the saved password entry in Keychain (which Safari pulls from) and retried with success.

The strange thing is that the saved credentials were among those that I had tried. So perhaps some other black magic was being carried over with the saved keychain entry.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.