Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a 32bit windows 2008 server, with IIS7.

have loaded up my .net4.0 web app and all i get is the grey screen with...

500 - Internal server error. There is a problem with the resource you are looking for, and it cannot be displayed.

No matter what i do, it will not show error details. customErrors="off" doesnt make any differece, there is nothing in the iis logs, nor can i find anything in event viewer.

i thought asp.net 4.0 was broken, but i tried uploading a plain asp.net 2.0 app to the same website, changing the app pool version to v2, and that gave the same error.

why on earth is it so difficult to get any information from iis7 in this situation? i dont even get the blue/white/red error details.

all other websites on the server are working fine (a variety of .net 2, 3, 3.5 and v4 apps)

i added elmah to my app, and that gives the same mystical error.

No Dice.

share|improve this question
    
Does it give any better error information if you load the page from the server (ie, from 127.0.0.1)? –  Shane Madden Apr 5 '11 at 20:15
    
Feel you must have done this but just going to ask. Did you make sure you have the correct default document at the top of the list? –  Campo Apr 5 '11 at 21:28

2 Answers 2

up vote 1 down vote accepted

I couldnt browse it locally by default (probably the firewall) - i had to wire a mock domain in using the hosts file and looping it back to the IP the site was bound to.

this then gave me the full error details which was insufficient permissions on web.config.

so, the reason why it couldnt show the detail is because it couldnt even read the web.config to read my instruction of 'show me the error details' (customErrors="off")

share|improve this answer
    
Baldy you should post this as an edit to your original question, a new question all together or as comments to your original question. But not as an answer. –  Brent Pabst Aug 15 '12 at 12:46
  1. If you are using IE - Turn friendly errors off in your browser settings

  2. See if this helps http://blogs.iis.net/bills/archive/2006/10/19/Improving-Custom-Errors-for-IIS7-Server.aspx

(e.g. like Shane suggested to try connecting to your web application from the web server itself (locally)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.