Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have created the file ~/.ssh/environment in there I put:

LEVEL=0

When I run a script over ssh to get the environment variable level it returns 0 like it should.

In the authorized_keys file I have several keys and am trying to change the value on a few so when I run a script on the other side it can modify how it process information. I am adding the following before the normal key:

command="/path/to/script" environment="LEVEL=1"

If I don't have the environment segment the script is executed fine, but if I have the environment part set then the script won't run.

I am not exactly sure what I am doing wrong. Am I even approaching this correctly?

essentially I have 4 different keys and in some cases I want people to have a level 1 or 2 with the default of 0, but I want to set who has the level and have it only set while they are logged in to execute their command.

I think I am barely understanding how it is supposed to work so my understanding could be completely wrong on how this should work.

Any ideas?

share|improve this question
1  
You need commas between the options. But you don't actually need the environment option, see toppledwagon's answer. –  Gilles Apr 5 '11 at 22:54

2 Answers 2

up vote 1 down vote accepted

Try this:

command="export LEVEL=1; /path/to/script"
share|improve this answer
    
That worked like a charm. Thanks. –  percent20 Apr 6 '11 at 0:02

First guess is that your syntax is slightly off.

I've never personally used the "environment" argument before, but from having to write custom authorized_keys entries before, I believe that optional arguments at the beginning of an authorized_keys entry require commas between each argument, not spaces.

Try:

command="path/to/script",environment="LEVEL=1" ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAQEArestofkeyhere comment_stuff

Hope this helps.

share|improve this answer
    
That helped it to work most of the way. I am going to play with it a little bit more I think I might still have something off. For the meantime though I am going with toppledwagon's solution. Thanks. –  percent20 Apr 6 '11 at 0:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.