Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to convert some machine's from a VM to another VM, both host ESXI 4.1, but I can never get past the screen where I select the VM and press Next, it will keep showing the message "Retrieving source machine info".

Now I have followed all guides on the internet: enabled SSH, checked .bashrc (that does not exists in ESXI 4.1??) etc.

I have 2 ESXI 4.1 servers in the network, both are SSH responsive but neither I can convert. I tried multiple PC's to convert from but still it does not work...

What should I check next?

share|improve this question
up vote 2 down vote accepted

Are you performing a V2V on a live Linux machine? I believe, based on the following statement that when they mention the .bashrc file they are referring to the guest system, not the host (ESXi).

VMware vCenter Converter Standalone 4.0.1 Release Notes

"Converter Standalone fails to connect to a powered-on Linux source if the .bashrc file contains an echo statement Converter Standalone might fail to connect to a powered-on Linux source machine if the given login account has a .bashrc file that contains an echo statement. Converter Standalone uses the SFTP protocol to copy files on the source Linux system, and SFTP fails at receiving the echo statement in the .bashrc file. As a result, Converter Standalone might stop responding for 10 minutes while retrieving source machine information or might display the following error message: Unable to query the live Linux source machine. See Connection to a Linux source fails despite correct SSH configuration (KB 1009153) for troubleshooting tips. Workaround: Remove the echo statement from the .bashrc file. You can safely place this echo statement in the .bash_profile file. This does not affect conversion tasks."

share|improve this answer
are you sure? Because the machine is switched off ofcourse. But still that doesnt matter, what I didnt mention was that I try to convert a Windows 2008 machine. – YesMan85 Apr 6 '11 at 7:30
Your machine with VMware converter is within the same subnet as the hosts? If you haven't already done so try disabling any firewall/filtering software on the vmware converter machine. Do you have any other VM's on that host you can try converting? – Lemb Apr 6 '11 at 17:32
I realize this is a very old question, but your comment helped me find the answer, so I upvoted. Slight bit of additional info though, I found an echo in /etc/bashrc, commenting that line out fixed my hangup. – Dan R Jan 30 '13 at 17:22
This answer saved me as well after hours of head-scratching. Echo commands on other machines were fine, but the troublesome one echoed backslashes and they seemed to be the culprit in our version (VMWare vCenter Converter 5.5.2). – Kaivosukeltaja Oct 7 '14 at 7:23

I had the same problem converting a windows2008 from esxi 4.1 to a workstation image. after searching i didn't find any solution on the web. so thats what i have done :

  1. created another virtual machine on the esxi 4.1 server
  2. installed vmware converter on the newly created machine
  3. created a shared folder on my pc to put the output of the conversion in
  4. point the converter to use this shared folder

And i worked like charm

what i think is the reason for this is a closed port or something on the esxi server, as it only accepted operations from inside the server, and blocks any operations from outside

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.