Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Noob question, sorry, but I have Googled, and asked and no one knows.

Basically the option to configure the DNS server is greyed out, along with just about every other option. The only option available is Launch NSLookup. I tried to submit images but apparently I don't have the reputation points needed. :)

I have removed and added the DNS role a couple of times. The option to setup the DNS is greyed out. In fact, just about every option is greyed out.

What should I do? Just trying to set up some simple Alias and MX records. Thanks!

share|improve this question
    
So you've added DNS as a server role but in server manager it's still greyed out? Have you tried opening the DNS MMC snap-in (dnsmgmt.msc)? –  Lemb Apr 6 '11 at 0:27
    
Also take a look at the event logs, there's one dedicated to DNS. This will hopefully point to the problem. –  Chris Thorpe Apr 6 '11 at 0:41
    
Do you have local Admin rights on the server? –  Cheekaleak Apr 6 '11 at 2:45
    
@Chris Thorpe - looked through the event logs, found out the exact time it stopped working. Looks to be a problem with Active Directory. Couldn't load Active Directory, and then started throwing all sorts of errors. –  Joshua Dance Apr 7 '11 at 15:35
    
@Cheekaleak - Yes I have local Admin, seems to be related to Active Directory, so I am going to attack that angel. –  Joshua Dance Apr 7 '11 at 15:36

2 Answers 2

up vote 1 down vote accepted

Active Directory and DNS are tightly integrated. If you are running AD on this same server, and you've removed the DNS role from the server, you've probably stuffed AD quite badly.

If you have another AD-integrated DNS server in your environment, try setting your server's DNS entries to point to that remote server for its DNS lookups. Once you've done that, AD should be able to come up properly.

Once AD is up properly, you should be able to DCPROMO the server so that it's not a domain controller anymore, and once you've done that, you should be able to install a standalone DNS role without AD integration.

share|improve this answer

Is the DNS service started? If not, it needs to be.

share|improve this answer
    
Yes it is started and set to automatic. –  Joshua Dance Apr 7 '11 at 15:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.