Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Zend Server CE (http://www.zend.com/en/products/server-ce/) and i'm developing a project (Zend Framework) which requires uploading big files ( video, > 100MB ). I have been trying to configure php.ini according to numerous articles over the internet related to php configuration for big files uploads.:

file_uploads = On
upload_max_filesize = 200M
max_input_time = 1800
memory_limit = 256M
max_execution_time = 1800
post_max_size =204M

The problem is bigger files (over few MB) still can not be uploaded. I have also tried to use uploadify flash uploader (http://www.uploadify.com/), but when i try to upload bigger files (outside localhost) the problem persists. I have tried this with ready made samples from uploadify website, which means that the problem is not in my project.

I am probably not configuring the server properly for uploading big files.

share|improve this question
    
How does your "does not work" look like? Do you have anything in your apache error logs? Is your PHP script actually called after the upload is finished? If this is the case, how does the $_FILES array look like? –  fab Apr 6 '11 at 8:54
    
When i try uploading locally if the file is less than 200MB works fine. $_FILES array on processing script contains needed file data. But problem happens when i try to do the same but from another computer. Locally if i try to upload bigger file than the upload_max_filesize i get php error: POST Content-Length of 366992037 bytes exceeds the limit of 213909504 bytes - which is fine. –  user77317 Apr 6 '11 at 13:42
    
When i am using Uploadify flash uploader (not locally) i usually get IO error - (given by the uploader, i'm not sure what does it mean) and the PHP script is not started. –  user77317 Apr 6 '11 at 13:45
    
in short: when i upload locally (no network speed limit) uploads work fine, when i try uploading over network does not work for bigger files (> few MB) –  user77317 Apr 6 '11 at 13:46
    
Could you post the "IO error"? –  Lekensteyn Apr 21 '11 at 8:12

1 Answer 1

After you make changes to any configuration files used by Apache, and that includes php.ini, you need to have Apache reload the files. This is most often done using apachectl graceful but as you haven't told us what OS you're using that command may ormay not be correct for you.

share|improve this answer
    
After changes in php.ini i do restart Apache using Apache monitor. So i guess apache reloads the configuration files needed. Am i wrong?? –  user77317 Apr 6 '11 at 13:38
    
I'm using Zend Server CE 5.0.2 (Apache/2.2.15 (Win32) mod_ssl/2.2.15 OpenSSL/0.9.8n, PHP 5.3.2) on Windows XP –  user77317 Apr 6 '11 at 13:40
    
@user77317, quite right, restarting Apache certainly does reload the configs. Nevertheless, what you are describing is just what happens when people change php.ini and don't reload it. –  John Gardeniers Apr 6 '11 at 19:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.