Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

SQLServer2008 is on a PC. When we upgraded to SQLServer2008, an ODBC error started to appear:

State: 37000,Native: 155,Origin: [Microsoft][Sql Natize Client][SQL Server]
'TRUNCATE_ONLY' is not recognized as a BACKUP option. 

Now this is error message has started to become a common occurrence. I am troubled.

How to downgrade it? Please help me

share|improve this question
add comment

3 Answers

The error is not a serious one. It's from your transaction log backup routine. (probably a SQL Agent job). You're trying to run "backup log [databasename] with truncate only" or something like that.

That's the old way of doing it. You can turn that script off, and set the database to "Simple" recovery mode, so your transaction logs don't grow out of hand.

Or set up a real transaction log backup.

But either way, stop trying to truncate the transaction log and you'll be fine.

share|improve this answer
    
Thank you for commented. Do you know contents to become that it does not serious –  freddiefujiwra Jun 15 '09 at 1:40
add comment

To add to what Bob says above, here's a long article I wrote on my blog about managing the size of your transaction log correctly: Importance of proper transaction log size management

share|improve this answer
add comment

The TRUNCATE_ONLY option for the log backup has been deprecated in MS SQL 2008. - One solution is to switch the database in simple recovery mode and then back to full recovery mode.

ALTER DATABASE *database_name* SET RECOVERY SIMPLE go

CHECKPOINT go

ALTER DATABASE *database_name* SET RECOVERY FULL go

  • Another option would be to checkpoint the databse and backup the log without the TRUNCATE_ONLY option (with a checkpoint and a log backup the log should shrink just enough)

CHECKPOINT go

BACKUP LOG *database_name* to disk = '' go

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.