Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've created a couple of distribution groups for our organization, and we'd like to start using these distribution addresses as our outgoing address (for things like support) rather than our personal email addresses.

To test, I've added "Send As" to myself for our support group, but I'm having some issues sending email.

  • If I manually type in our support email address (which is set as the primary [and only] email address for the DG) and send the email, I get the "You can't send a message on behalf of this user..." message from the postmaster and the email does not go out.
  • If I select the DG by clicking on "From..." and browsing the address book, then it works fine. Curiously, the DG does not show up in the GAL, but if I go to "All Groups", it appears
  • If I try to send another email by clicking on the entry that shows up in the "From" popup now, it fails again.

I'm willing to live with having to select the DG from the address book the first time, but having to browse to it every time is going to become tedious. Is there something that I'm missing here?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

If you are running in cached mode try coming out of cached mode and look in the GAL for the DG.

share|improve this answer
    
This, oddly enough, fixed it (or, rather made the groups show up in the GAL, which allowed me to send repeated messages). Switching back unfortunately takes it out; what do I need to do to fix this completely? –  Adam Robinson Apr 6 '11 at 17:02
    
Once your OAB is updated overnight (if you have the default update time of 5am) you should be fine. –  Cheekaleak Apr 6 '11 at 17:04
    
I tried forcing an update, but it did not appear to affect anything. –  Adam Robinson Apr 6 '11 at 17:05
    
Forcing an OAB update on the server doesn't immediately take affect especially if you have a large OAB. –  Cheekaleak Apr 6 '11 at 17:06
add comment

It sounds like your OAB hasn't updated to the client with the DG. Force an OAB update on the server and the client and try it again. The fact that the DG doesn't show in the GAL is usually indicative of an OAB mismatch.

share|improve this answer
    
I've forced an update to the OAB through EMC on the server and through Outlook on the client. No dice, unfortunately. Would this have an effect upon my ability to send from the address more than once, as I described? –  Adam Robinson Apr 6 '11 at 14:46
    
Have you tested a normal user and configure the permissions the same way? Does the same issue occur then? –  Holocryptic Apr 6 '11 at 15:02
    
I haven't tried another user yet, but I did just try changing a different DG. This DG does show up in the GAL (it's an older DG, whereas the one I've been testing with is brand new and I'm the only member) and appears to work fine. –  Adam Robinson Apr 6 '11 at 15:10
    
I'd start looking at your environment and make sure that your OAB updates are occuring. If you have a semi-complex environment it might be getting stuck somewhere. Barring that, double check permissions as well because I think EX2010 does send as vs. full mailbox control differently than at least 2003 (not sure about 2007). Also test with a normal user and see if you can reproduce. –  Holocryptic Apr 6 '11 at 15:16
    
@Holocryptic: Our environment is very simple: one Exchange 2010 server that handles all roles, and just a few workstations that connect to it. –  Adam Robinson Apr 6 '11 at 15:31
show 4 more comments

In order for this to work you need to create Mail-enabled Security group (Scope = Univesal)

share|improve this answer
    
This may have been true of previous versions of Exchange (I can't say one way or the other), but this does not appear to be true of 2010. –  Adam Robinson Apr 6 '11 at 17:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.