Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just finished configuring dnsmasq on a local machine and it seems to work fine when resolving domains using itself. When I point another machine on the network to use the dnsmasq machine as its sole DNS server, I can't get any domain to resolve at all.

My config files look like this (am I missing something?):

resolv.conf

nameserver 127.0.0.1

dnsmasq.conf

# resolv File
resolv-file=/etc/resolv.conf

# DNS Servers
server=131.191.7.5
server=131.191.7.12

# Domain Overrides
address=/mydomain.com/192.168.2.253
address=/one.mydomain.com/192.168.2.253
address=/two.mydomain.com/192.168.2.253
address=/thismachine.local/192.168.2.253

When I run "sudo lsof -i | grep LISTEN" I can see dnsmasq listening on port 53:

dnsmasq   189         nobody    4u  IPv4 0x05bf8338      0t0    TCP localhost:domain (LISTEN)
dnsmasq   189         nobody    6u  IPv6 0x05bf31f0      0t0    TCP uberserve.local:domain (LISTEN)
dnsmasq   189         nobody    8u  IPv6 0x05bf2f80      0t0    TCP localhost:domain (LISTEN)
dnsmasq   189         nobody   10u  IPv6 0x05bf2d10      0t0    TCP localhost:domain (LISTEN)
share|improve this question

1 Answer 1

up vote 2 down vote accepted

What's your firewall look like on the dnsmasq box?

Check inbound port 53.

Run a packet trace on your new dnsmasq box on port 53 and see what's happening.

You can force a client to use your dnsmasq box like so:

dig www.google.com @dnsmasboxip

share|improve this answer
    
So port 53 is definitely being blocked somehow, but I don't have any firewalls or utilities blocking it. Are there any recommended places to check in OS X for the culprit? –  Wilco Apr 7 '11 at 4:16
    
Try here: support.apple.com/kb/ht1810 –  dmourati Apr 7 '11 at 4:25
    
Currently I have Apple's included firewall completely disabled. –  Wilco Apr 7 '11 at 4:29
    
How about: lsof -i4udp –  dmourati Apr 7 '11 at 4:57
    
Hmmm, I don't see anything for dnsmasq for that. Is it weird that it seems to be listening on port 53 with TCP and not UDP? –  Wilco Apr 7 '11 at 5:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.